[Adapt] Galaxy Disk Cleanup

Luo Kangqi luo.kangqi at qq.com
Mon Mar 20 01:01:55 CST 2017

Hi All,

The disk space on Galaxy is running pretty low, and we are going to do some cleanup.
Please check your disk occupation and delete unused files on Galaxy before 2pm, Feb. 22th. Otherwise Kenny and I may go in and delete files on our own behalf.

Kangqi Luo, PhD Candidate
ADAPT Lab, SEIEE 3-341
Shanghai Jiao Tong University


------------------ 原始邮件 ------------------
发件人: "Kenny Zhu";<kzhu at cs.sjtu.edu.cn>;
发送时间: 2017年3月19日(星期天) 晚上9:25
收件人: "'邢俊劼'"<jjxing at sjtu.edu.cn>; 
抄送: "Luo Kangqi"<luo.kangqi at qq.com>; 
主题: RE: 【Health Project】"No space left on device" error

Probably galaxy is out of space. There’s no individual quota on galaxy. Kangqi, can you help deleting some unused files on galaxy?




From: 邢俊劼 [mailto:jjxing at sjtu.edu.cn] 
Sent: Sunday, March 19, 2017 9:22 PM
To: Kenny Zhu
Subject: 【Health Project】"No space left on device" error



       I ran the program which meant to add “url” and “keshi” into the data set on Friday after I checked that it performed well on my device.

       Yesterday when I check for process I found that the size of the new data set is unexpected 0. I first thought that it was caused by multiprocessing because of I/O conflicts for the function performed well when single process calling on galaxy too. But after I added lock into the program it still outputs the same result, it confused me a lot.

       Just now after I added more “try-except”into my function, I found that the pickle.dump() come out an “IOError: [Errno 28] No space left on device” which was not caught by python when I didn’t explicitly catch it.

       So the problem is that my directory is out of space. Is that because galaxy has a space limit on user folder? How can I solve the problem?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://cs.sjtu.edu.cn/pipermail/adapt/attachments/20170320/871740bf/attachment.html>

More information about the Adapt mailing list